Ticket #45 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Strabon hangs when a ternary spatial function is the argument of a unary spatial function

Reported by: dbilid Owned by: giannis
Priority: minor Milestone: Strabon v3.2.11
Component: postgis Version: all
Keywords: Cc:

Description

example:
strdf:envelope(strdf:buffer(?y1, "0.5"xsd:float, <http://www.opengis.net/def/uom/OGC/1.0/metre>))

The problem is in method appendGeneralDBSpatialFunctionUnary of class PostGISQueryBuilder. (tmp becomes null and runs on infinite loop in the while)

Change History

comment:1 Changed 3 years ago by psmeros

  • Milestone set to Strabon v3.2.10

comment:2 Changed 3 years ago by psmeros

  • Owner changed from pyravlos-team to giannis
  • Status changed from new to assigned

Related to ticket #48.

comment:3 Changed 3 years ago by giannis

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.