Ticket #70 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

strdf:srid and geof:getSRID functions do not work in the SELECT clause for constant geometry literals

Reported by: charnik Owned by: pyravlos-team
Priority: major Milestone: Strabon v3.2.11
Component: generaldb Version: 3.2.9
Keywords: geof:getSRID, strdf:srid, select clause, constant Cc:

Description

The following query must return the associated SRID of the projected geometries, but it doesn't (tested on NOA endpoint).

PREFIX geo: <http://www.opengis.net/ont/geosparql#>
PREFIX geof: <http://www.opengis.net/def/function/geosparql/>
PREFIX strdf: <http://strdf.di.uoa.gr/ontology#>

#SELECT (strdf:srid("POINT(37 23)"strdf:WKT) as ?srid)
SELECT (geof:getSRID("POINT(37 23)"geo:wktLiteral) as ?srid)
WHERE {

FILTER NOT EXISTS {<http://ex.org/a> <http://ex.org/b> <http://ex.org/c>}

}

Change History

comment:1 Changed 3 years ago by charnik

  • Status changed from new to closed
  • Resolution set to fixed

This behavior does not have to do with these extension functions, but it has to do with FILTER NOT EXISTS. Thus, it is a duplicate of Bug #72. Therefore, it is marked as fixed.

Note: See TracTickets for help on using tickets.