Ticket #82 (closed defect: fixed)

Opened 15 months ago

Last modified 7 weeks ago

Error loading google maps in strabon endpoint

Reported by: constant Owned by: tioannid
Priority: major Milestone:
Component: endpoint Version:
Keywords: Cc:

Description

Getting the following errors trying to project the results of queries on the map (KML format options) in Strabon endpoint:

Uncaught TypeError?: Cannot read property 'ownerDocument' of undefined
js:34 Google Maps API error: MissingKeyMapError? https://developers.google.com/maps/documentation/javascript/error-messages#missing-key-map-error

The first occurs in timeline library (we are currently using version 1.2).
The second seems to be related to recent changes in the Google Maps API described here: https://googlegeodevelopers.blogspot.gr/2016/06/building-for-scale-updates-to-google.html

Issue reported by Peter Lavin. Reproduced using both Tomcat 7 and Tomcat 8.
Keep in mind that the problem appears to apps created after June 22 or
existing apps that changed domain.

Users can try the following options until the problem is solved:
1) If you have an existing working instance of Strabon endpoint, deploy all new versions of your applications under the same domain

2) You can use the visualization tool Sextant http://sextant.di.uoa.gr/. Sextant is able to connect to a Strabon (or any (Geo)Sparql endpoint and project the results of spatial queries on a map, using OpenLayers?.


Change History

comment:1 Changed 7 weeks ago by constant

  • Owner changed from pyravlos-team to tioannid
  • Status changed from new to assigned

comment:2 Changed 7 weeks ago by tioannidis

  • Status changed from assigned to closed
  • Resolution set to fixed

Solved in changeset 1536:f287cc1b8b99.

An extra field "googlemapskey" has been added to the "connection.properties" file which stores the Google Maps API Key for the site. The key can be specified in the Configuration page (connection.jsp). The user can specify the values "" or "null" to specify that no key is provided.

When no key is given the context path is restricted to the default value, which allows existing users to continue working as usual.
When a key is provided the context path can be changed to the desired value.

Last edited 7 weeks ago by tioannidis (previous) (diff)
Note: See TracTickets for help on using tickets.